Tuesday, 15 May 2012

AIX TL/ML Migration/Upgradation with MultiBOS method


AIX ML/TL Migration/Upgradation can be done in many ways. I am here sharing the method, which worked for me.


Current TL/ML Level
  • # oslevel –s             >>> Show current AIX Fix Level
  • # lppchk –v              >>> Show installed packages
  • # instfix -i | grep ML   >>> Show the currently installed ML
  • # lslpp -l | grep -i applied >>> Check for any applied level packages
  • # installp -c -f -g –X       >>> Commit all the applied level packages
Creating MultiBOS instance
  • # multibos -sXp         >>> Pretend MultiBOS creation(Mock Run)
  • # multibos -sX          >>> MultiBOS instance creation
Install the TL/ML updation from location
  • # mount nimmaster:/export/5300-12-00-1015 /shared >>> Mount the TL files source
  • # multibos -Xacp -l /shared  >>> Pretend TL/ML migration on Standby BOS(Mock Run)
  • # multibos -Xac -l /shared   >>> TL/ML migration on Standby BOS
Confirming the Update Success
  • # multibos –S           >>> Login to Standby BOS environment
  • # oslevel –s            >>> Check whether migration succeeded
  • # lppchk –v             >>> Check the lpp health after migration
  • # instfix -i | grep ML  >>> Show the currently installed ML
  • # oslevel –rl 5300-12   >>> Incase of problem to know the missing pkg
  • # multibos -Xc -b /tmp/listofpkgs -l /shared  >>> Install missing, if req
Checking the BootLV Change
  • # bootlist -m normal –o
Reboot the Server and check the Applications is running properly
  • # shutdown –Fr
Fallback (Point the BLV to the original LV -- hd5)
  • # bootlist -m normal –o hdisk0 blv=hd5 hdisk0 blv=bos_hd5
Log files
  • /etc/multibos/logs/op.alog >>> For MultiBOS install and create operation
  • /etc/multibos/logs/scriptlog.<timestamp>.txt >>> For the MultiBOS Shell operation log
Remove MultiBOS, if you are satisfied with the new TL/ML
  • # multibos –RXp
  • # multibos –RX

    * Source Article from : Internet