Friday, 20 April 2012

AIX COMMANDS

VG Commands

lsvg                                                         Display all VGs
lsvg -o                                                    Display all active VGs
lsvg rootvg                                            Display info about rootvg
lsvg  -l rootvg                                        Display info about all LVs in rootvg
lsvg -o |lsvg -il                                      Display info about all LVs in all VGs
lsvg  -p rootvg                                       Display info about all PVs in rootvg
mkvg  -s 8 hdisk1                                Create VG with name vgxx on hdisk1 with partition size 8MB
mkvg -s 8 -y sivg hdisk1                    Create VG with name sivg on hdisk1 with partition size 8MB
mkvg -s 4 -t 2 -y sivg hdisk1             Create sivg on hdisk1 with PP size 4 and no of partions 2 * 1016
chvg -a y newvg                                    To cuase VG newvg automatically activated at startup
chvg -a n newvg                                    To deactivate the automatic activation at startup
chvg -t 2 newvg                                     To change maximum no. of PP to 2032 on vg newvg
chvg -Q n newvg                                   To disable quorum on VG newvg
reorgvg  newvg                                     Reorganises PP allocation of  VG newvg
extendvg newvg hdisk3 hdisk4         Add PV hdisk3 and hdisk4 to VG newvg
exportvg newvg                                     Exports the VG newvg
importvg -V 44 -y newvg     hdisk2   Import the hdisk2 with name  newvg, and assign major number 44
redcucevg newvg hdisk3                    Remove PV hdisk3 from VG newvg
varyoffvg newvg                                    To deactviate VG newvg
varyonvg newvg                                    To activate VG newvg
syncvg -v sivg                                       To sync the mirrored LV in the VG sivg
mirrorvg -S -m sivg hdisk2               To mirror LVs of sivg with hdisk2 (-m for exact mirror, -S
forbackground  mirror)
unmirrorvg sivg hdisk2                     To remove the mirrored PV from the set.

FS Commands


lsfs                                                         Lists all filesystems in the /etc/filesystems entry
lsfs -q                                                     List all filesystems with detailed info
lsfs -a                                                     To list all filesystems (default)
lsfs -l                                                      Specify the output in list format
lsfs -c                                                     Specify the output in column format
lsfs -v jfs                                                Lists all jfs filesystems
chfs -a size=24576 /si                        Change size of FS /si to 24576 x 512 bytes blocks (12 MB)
chfs -a size=+24576 /si                      Add 24576 x 512 byte blocks to FS /si
chfs -m /si /bi                                       Change the mount point from /si to /bi
chfs -A /si                                             To auto mount the filesystem si
chfs -d account /si                               Remove account attribute of /si. ( from /etc/filesystems file)
chfs -a splitcopy=/backup -a copy=2 /oracle 
                                                          This will mount the 2nd copy of mirrored filesystem oracle to  /backup                in read-only mode
crfs -v jfs -g testvg -a size=64465 -m /siju   
                                                          Creates FS /siju of type jfs in VG testvg of blocksize 64465
crfs -v jfs -d /dev/lv00 -m /siju           Create FS /siju of type jfs on device /dev/lv00
rmfs /siju                                              Deletes FS /siju and associated LV
rmfs -r /siju                                          Deletes FS /siju its mount point and associated LV
defragfs /sifs                                        To defragment the file system /sifs
defragfs -q /sifs                                    Display the current defrag status of the file system
fsck  -y n /dev/lv00                              To fsck the filesystem associated to /dev/lv00 assuming response "yes"
fsck -p /dev/lv00                                   To restore superblock from backup superblock 



PV Commands


lspv hdisk0                                           Display status and characteristics of the PV
lspv -p hdisk0                                       Display  PP usage of hdisk0                                                              
lspv -l hdisk0                                        To list all logical volumes on PV hdisk0
chpv -v r hdisk1                                   Close the PV (Used while removing PV without varyon)
chpv -v a hdisk1                                   Open the PV
chpv -c hdisk0                                      Clear the master boot record on PV hdisk0
migratepv  hdisk1 hdisk2  To move PPs from PV hdisk1 to hdisk2
migratepv -l silv hdisk1 hdisk2        To migrate LV silv from PV hdisk1 to hdisk2

LV Commands


lslv -l lv00                                             Display info about LV by PV
lslv -p hdisk1                                        Display LV allocation map for hdisk1
chlv -t copy lv00                                   To change the lv00 to copy type
chlv –n silv lv00                                   To rename lv00 to silv
chlv -p r lv00                                         To change the lv00 to readonly mode
rmlv silv                                                To remove silv
rmlv -f silv                                             To remove silv without user intervention
mklv  -s n -c 3 silv hdisk1                  To make LV silv  with three copies on hdisk1
extendlv  silv 5                                      To extend the LV silv with 5 LPs
mklvcopy -s n lvsi 2 hdisk1               To mirror LV lvsi on same PV with 2 copies
mklvcopy lvsi 3 hdisk1 hdisk2         To mirror LV lvsi on PV hdisk1 and hdisk2 with 3 copies
rmlvcopy lvsi 2 hdisk1                       Will remove one copy of  LV lsvi from hdisk1
mklv -t jfslog -y log00 newvg 2         To create a jfslog with name log00 on VG newvg with 2LPs
logform /dev/log00                              To format jfslog volume log00

BLV Commands


bootlist -m normal -o                           To see the boot sequence in normal mode
bootlist -m service -o                           To see the boot sequence in service mode
bootlist -m normal cd0 hdisk0          To change boot sequence to cd0,hdisk0 in normal mode
bootlist -m service cd0 rmt0 hdisk0  To change boot sequence to cd0,rmt0,hdisk0 in service mode
bosboot -ad /dev/hdisk1                      To create boot image on PV hdisk1
mkboot -cd /dev/hdisk1                      To clear the boot image
bootinfo -b                                             Specifies the bootable disk
bootinfo - t                                             Specifies the type of boot
bootinfo -e                                             Check the machine can boot from tape
bootinfo -T                                             To see the machine hardware type
bootinfo -s hdisk0                                To see the size of hdisk0
bootinfo -r                                             To see the size of memory
bootinfo –k                                            To see the key position
bootinfo –m                                           To see the machine model code
bootinfo –o hdisk0                               To list the location code of hdisk0
bootinfo –z                                            To see the machine is multiprocessor capable
bootinfo –p                                            To see the machine

Paging Space Commands


lsps -a                                                    To list out all paging spaces
lsps hd6                                                 To display the details of the paging space hd6
chps -a y paging00                              To turn on the paging space paging00
chps -a n paging00                              To turn off the paging space paging00
chps -s4 paging00                               To increase the size of the paging space in 4 LP blocks
mkps -a -n -s4 sivg                              To create a paging space on VG sivg of 4 LP size (-s4) and activate it
immediately (-n) and activate it at every restarts
rmps paging00                                     To remove the paging space paging00
swapon -a                                               To invoke all entries in /etc/swapspaces file
swapon /dev/paging00                         To make available swap space paging00


SYSTEM DUMP Commands


sysdumpdev -l                                       To list the current dump destination
sysdumpdev -L                                      List the details of the previous dump
sysdumpstart -p                                   Starts dump in the primary dump device
sysdumpstart -s                                   Starts dump in the secondary dump device
sysdumpdev -p /dev/lv00                     To make lv00 as primary dump device
sysdumpdev -P -p /dev/lv00                To make lv00 as primary dump device permanently
sysdumpdev -s /dev/rmt0                    To make rmt0 as secondary dump device
sysdumpdev -z                                      To determine a new system dump occurred

Device related commands


cfgmgr                                                   To configure devices and installs device software in system
cfgmgr -l vscsi0                                   To configure the components connected to the vscsi0 interface
lscfg                                                       To display config, diagnostics and vital product definition info
lscfg -l mem0                                       Display info about device mem0
lscfg -l ent*                                          Display info about all Ethernet cards
lscfg -v                                                   Display vpd
lscfg -v -l hdisk0                                  Display vpd of hdisk0
mkdev    -l rmt0                                   To change device rmt0 from defined state to available state
lsdev -P                                                  To lists all supported devices
lsdev -P -c disk                                     To list all supported disks
lsdev -P -r class                                   To display supported class
lsdev -P -r subclass                             To display all sub class
lsdev -C                                                  To lists all configured devices
lsdev -C -l mem0                                  To display the properties of mem0
chdev -l sys0 -a maxproc=100           To change default maxproc value to 100
chdev -l rmt0 -a blocksize=512        To change the block size to 512
chdev -l rmt0 -a ret=no                       To avoid tape retension
rmdev -l rmt0                                       To remove the device rmt0
rmdev -d -l rmt0                                   To remove the device totally from database
rmdev -l rmt0 -S                                  To change the state of the device stopped
lsparent -C -k  rs232                          To display possible parent devices which accept rs232 devices
lsparent -C -l hdisk0                          To display parent devices which accept child device hdisk0
lsattr -Dl rmt0                                     To see the default values of the device rmt0
lsattr -El rmt0                                      To see the current values of the device rmt0
lsattr -El tty0 -a login -R                    To see all possible values of the login attribute of tty0
lsconn -p scsi0                                     To list all possible connection scsi0 can accept
lvlstmajor                                              To list the available major numbers
mknod /dev/null c 2 2                         Create null device with major (2) and minor (2) nos. (c - char device)

Console Emulation Commands


lscons                                                    To list the current console
lscons -b                                                To list the console at next boot
chcons /dev/tty3                                   To change the console to tty3
chcons -a login=enable /dev/tty3      Redirect console to tty3 and provide login prompt
swcons /dev/tty3                                   To change system console to tty3 temporarily
alog  -L –t console                               To see the current attributes of log type console
alog –t console –o                                To see the console messages
alog –t boot –o                                      To see the boot time messages

Installation specific commands


lslpp -l                                                    To see the details of installed file sets
lslpp -ha bos.net.*                                To list the installation history of all file set in bos.net packages
lslpp -f bos.rte                                      To list the files in the bos.rte package
lslpp -w /etc/hosts                                To list the file set which contain /etc/hosts file
lslpp -p bos.net.nfs.server  To list the pre requisites for bos.net.nfs.server file set
installp -L -d /dev/rmt0.1                   To list the installable products on the device rmt0
installp -aX -d /dev/rmt0.1 bos.net To install all filesets within bos.net & expand file system if  required
installp -u bos.net                                To remove bos.net
installp -r                                              To reject the applied software
installp -c -f <product>                       To commit the <product>
installp -C                                             To cleanup an incomplete installation
lppchk -c <product>                            To check the <product>
instfix -k IX9999 -d /dev/rmt0.1       To install the file set associated with fix IX9999 from rmt0
instfix  -ik IX9999                              To verify fix IX9999 installed

Network related commands


host 193.9.200.1                                  Resolves ip to host name (from /etc/hosts file)
host ibm                                 Resolve ibm to ip address (from /etc/hosts file)
hostname ibm                                       To change the host name to ibm
entstat en0                                            To the status of ethernet device en0
entstat -d en0                                        To list the detailed status of device en0
no -a                                                       To list all net configurable attributes and their values
no -d thewall                                         To change thewall parameter to its default value
no -o ipforwarding=1                          To make the machine as router in tcpip networks
traceroute ibm                                     To trace the route to ibm
ping ibm                                                To tcp ping to the machine ibm
ifconfig -a                                              To show the status of all network interfaces
ifconfig en0                                          To show the status of en0
ifconfig en0 up                                     Turns on network card en0
ifconfig en0 down                                Turns off network card en0
ifconfig en0 detach                              Removes en0 card from the network interface list
ifconfig en0 inet 194.35.52.1 netmask 255.255.255.0 up         
                                                                Configure en0 starts immediately
ifconfig en0 alias 195.60.60.1          Create alias ip address for en0
route add 0 192.100.13.7                   To make 192.100.13.7 as default gateway for entire network
route add 192.100.12.0  192.100.13.7   To make 13.7 as gateway for 12.0 network
route -f                                                   To clear the gateway table
chdev -l inet0 -a hostname=si            To change the host name to si permanently
netstat -a                                               To show the state of all sockets
netstat -c                                               To show the network buffers cache
netstat -D                                              To show the net drops of packets
netstat -i                                                To display interface statistics
netstat -r                                               To show the routing table
netstat -rn                                             To show routing table (ip will be given instead of host names)
netstat -s                                              To show the statistics of the protocols
netstat -s -p < tcp/udp/ipv6>               To show the statistics of respective protocols

Space usage commands


du -k                                                       To list number of bytes in 1k blocks
du -l                                                        To list number of bytes in 512 bytes blocks
du -s                                                       To list only the total disk usage in the current directory
df -i                                                         To display no of free and used inodes
df -k                                                        To display diskspace in 1024 bytes format

Backup commands

mksysb -i -X /dev/rmt0                       Creates image.data and system backup (-X expands /tmp if required)
mksysb -m /dev/rmt0                          Creates image.data file with map file and system backup
mksysb -e /dev/rmt0                           Creates system data but excludes the files listed in /etc/exclude.rootvg
mkszfile                                                                Creates /image.data file
mkcd -d /dev/cd1                                  Creates system boot backup to the CD-R device /dev/cd1
mkcd -d /dev/cd1 -v vg00                    Creates  backup of vg vg00 to CD-R device /dev/cd1
mkcd -d /dev/cd1 -G                             Creates  generic boot backup
savevg -i -f /dev/rmt0 vg00 Creates vg00.data image file and backup vg vg00
savevg -ef  /dev/rmt0 vg00                  Creates vg00 backup but excludes files listed in the /etc/exclude.vg00
find / -print | backup -ivf /dev/rmt0  Backup entire system to rmt0
backup -0vf /dev/rmt0 /home             Backup /home directory to rmt0 with backup level 0
restore -Tvf /dev/rmt0                        List the archive in rmt0
restore -xvf /dev/rmt0 /home             Restore /home from archive in device rmt0
find ./home -print |cpio -ocvumB > /dev/rmt0
Archives /home directory
cpio -icvdumB < /dev/rmt0 Restores cpio archive from rmt0
cpio -ivt < /dev/rmt0                            List the contents of cpio archive from rmt0
cpio -icvd < /dev/rmt0 /home              Restores /home directory from rmt0
tar -cvf /dev/rmt0 /home                    Archives /home to rmt0 device
tar -tvf /dev/rmt0                                  List the archives in rmt0
tar -xvf /dev/rmt0 /home                     Extract /home from rmt0
dd if=si of=si1 conv=ebcdic                Convert and copy ascii file si to ebcdic si1
dd if=/dev/rmt0 ibs=512 obs=1024 of=/dev/rmt1
                                                                To copy blocks from rmt0 with 512 blocks to rmt1 with 1024 blocks
tctl -f /dev/rmt0 rewind                       To rewind the tape
tctl -f /dev/rmt0 offline                       To eject the tape
tctl -f /dev/rmt0 status                        To show the status of tape
chdev -l rmt0 -a block_size=512      To change the block size of the tape to 512

Print commands

qchk -q                                                   To display the default q
qchk -P lp0                                           To display the status of the printer lp0
qchk -# 123                                          To display the status of job number 123
qchk -A                                                  To display the status of all queues
qcan -x 123                                           To cancel the print job 123
qcan -X -P lp0                                       To cancel all jobs submitted to lp0
qpri -#570 -a 25                                   To change the priority of the job to 25
qhld # 569                                             To hold the  job 569
qhld -r -#569                                        To remove holding from 569
qmov -m lpa -#11                  To move the job 11 to queue lpa
enable psq                                             To enable queue psq
disable psq                                            To disable queue psq
cancel -#111                                         To cancel job 111
lpstat                                                      To display the status all queues
lpstat -p lp0                                           To display the status of print queue lp0
lpstat -u root                                         To display the jobs submitted by user root
lpq -P lp0                                               To display the status of queue lp0

last                                                         To list all the records in the /var/adm/wtmp file
last |grep shutdown                             To show the shutdown sessions
uptime    (w -u )                                     To show how long the system has been up

Licensing commands


oslevel                                                    To list the operating system level
lslicense                                                                To see the number of license
chlicense -u30                                     To change the fixed user license to 30
chlicense -f  on                                     To enable floating user license

User commands

id                                                             To list all system identifications for current user
id -gn                                                      To list the default group for current user
id -Gn                                                     To list all system groups for current user
lsuser root                                            To list the attribute of user root
lsuser ALL                                           To list the attributes of all users
lsuser -a HOME ALL                         To list the home directory of all users
lsuser -a ALL                                       To list all usernames
lsuser -a auth1 auth2 ALL                To list the authentication method for all users
lsuser -a expires ALL                        To list expiry date
lsuser -a account_locked ALL         To check account lock status of all users
chuser -a login=true san                   To enable the user san
chuser -a rlogin=true san                 Enable san to login remotely
mkuser si                                             Creates user si with default values in /usr/lib/security/mkuser.defalault
mkuser su=false si                             Create user si without su facility
rmuser si                                              To remove user si
rmuser -p si                                          To remove user si and his all attributes
who                                                         List users with tty nos and ip numbers
who /var/adm/wtmp                              Lists history of login logout system startup and shutdowns
who -r                                                     To list the run level
who am i /who -m                 To list the current user
mkgroup dcm                                       To create the group dcm
chgroup users=u1,u2,u3 dcm           To add users u1 u2 and u3 to dcm  group
rmgroup dcm                                        To delete the group dcm
chauthent                                              To change the authentication methods

Subsystem Commands

lssrc -a                                                  To list the status of all subsystems
lssrc -h node1 -a                                  To list the status of all subsystems  on foreign host node1
lssrc -s kadmind                                  To list the status of the subsystem kadmind
lssrc -g tcpip                                        To get the status of the subsystem group tcpip
mkssys                                                  To add a subsystem
rmssys -s kerberos                             To remove the subsystem kerberos
chssys -s kerb -s kad                          To rename the subsystem kerb to kad
startsrc -s kadmin                              To start the subsystem kadmin
startsrc -g tcpip                                   To start the subsystem group tcpip
stopsrc -s kadmin                                To stop the subsystem kadmin
stopsrc -g tcpip                                    To stop the subsystem group tcpip
refresh -s nfsd                                     To refresh nfsd subsystem
refresh -g tcpip                                    To refresh tcpip subsystem group

Scheduling commands

crontab -l                                               To list the crontab entries
crontab -e                                              To edit the crontab entries
crontab -l > /si                                      To copies the entries of crontab to /si file
crontab -r                                              To remove all crontab entries
crontab -v                                              To list the submission time
/var/adm/cron/cron.allow   File containing users who allowed cron service
/var/adm/cron/cron.deny                    File containing users denied cron service
at -l                                                         To list the jobs scheduled via at command
at -r  root.dfjdhjdh.21                          To remove the scheduled job root.dfjdhjdh.21
/var/adm/cron/at.allow                        File containing users who allowed at service
/var/adm/cron/at.deny                         File containing users denied at service
batch                                                      To run the command when the system load permits
atq  joe                                                   To list all the jobs submitted by user joe

ODM Commands

odmget   sm_menu_opt                   To get the objects from class sm_menu_opt
odmget -q "id=licenses" sm_menu_opt
                                To list objects that matches query id=licenses from object sm_menu_opt
odmdelete -o sm_menu_opt -q "id=licenses"
                                To delete the entries from class sm_menu_opt which agrees the query id=licenses
odmshow sm_menu_opt                     To show the object class definition
odmdrop -o sm_menu_opt To drop sm_menu_opt object class
odmchange -o sm_menu_opt -q "id=licenses" file1  To change the attributes from file1

errpt                                                       To display complete summary of report
errpt -a                                                  To list complete detailed report
errpt -d H                                              To list all hardware related errors
errpt -d S                                               To list all software related errors
errpt -a -j 34564423                           To list detailed error report of error id 34564423
chitab tty002:23:respawn:/usr/sbin/getty /dev/tty
                                                                To enter the entry tty002:23:respawn:/usr/sbin/getty /dev/tty in inittab
lssrc -g portmap                                  To start tcpip


Daemons of NIS

Server                                    Slave Server                         Client

ypserv                                    ypserv                                    ypbind
yppasswd
ypupdated

NIS maps created by default (if file available on master server)
MAP
FILE
NICK NAME
passwd.byname
passwd.byaddr
/etc/passwd
passwd
group.byname
group.byaddr
/etc/group
Group
hosts.byname
hosts.byaddr
/etc/hosts
Hosts
ethers.byname
ethers.byaddr
/etc/ethers
Ethers

networks.byname
networks.byaddr
/etc/networks
Networks
rpc.bynumber
/etc/rpc

services.byname
/etc/services

protocols.byname
protocols.bynumber
/etc/protocols
protocols
netgroup.byhost
netgroup.byuser
/etc/netgroup

bootparams
/etc/bootparams

mail.aliases
mail.byaddr
/etc/aliases
aliases
publickey.byname
/etc/publickey

netid.byname
/etc/passwd
/etc/group
/etc/hosts
/etc/netid

netmasks.byaddr
/etc/netmasks


chypdom –I mca                                   Modifies nis domain name entry in /etc/rc.nfs
chypdom –B mca                  Changes nis domain and modifies /etc/rc.nfs file
chypdom –N mca                  Changes nis domain name to mca
domainname  mca                                Changes nis domain name to mca until next reboot
mkmaster                                             To make the machine NIS master
                                                                Options:
                                                                                -O           Overwrites existing maps
                                                                                -o             prevents overwriting existing maps
                                                                                -E            Exit on errors
                                                                                -e             No exit on errors
                                                                                -P            Starts yppasswdd daemon
                                                                                -p             Don’t start yppasswdd daemon
                                                                                -U            Starts ypupdated daemon
                                                                                -u            Don’t start ypupdated daemon
                                                                                -C            Starts ypbind daemon
                                                                                -c             Don’t start ypbind daemon
                                                                                -B            Executes ypinit command and modifies rc.nfs
mkclient –B –S mca                           Makes the machine as a client of mca server and starts ypbind daemon
ypcat  passwd                                        To cat the password map file passwd.byname
ypcat –x                                                 To display map nickname translation table
ypcat –d pci passwd                             To display the passwd file in the domain pci
yppasswd                                               To change the password of nis user
lsmaster                                                Display characteristics for the configuration of NIS master
mrgpwd  >/var/yp/passwd   To merge /etc/passwd and /etc/security/passwd file to /var/yp/passwd
ypxfr  -h mca passwd.byname            To transfer password map file from host mca

Procedure for NIS
Master Server
Change the nis domain name in the master server
        chypdom –B mca
                        or
        smit chypdom
Verify tcpip is running by executing  lssrc –s inetd
Verify portmap is running by executing lssrc –s portmap
(For security reason it is better to locate all nis files to /var/yp directory and change the DIR=/etc entry to DIR=/var/yp in the /var/yp/MakeFile.  For merging the existing passwords execute
mrgpwd > /var/yp/passwd)
Execute mkmaster –O –E –P –U –C –B
                        -O           Overwrites existing maps for this domain
                        -E            Exist on errors when creating master server
                        -P            Starts yppasswdd daemon
                        -U            Starts ypupdated daemon
                        -C            Starts ypbind daemon
                        -B            Executes ypinit command, uncomment entries in rc.nfs and starts daemons
Check the yp daemons with lssrc –g yp

Slave Server
Change the nis domain name
                chypdom –B mca
Edit hosts file, keep entries for loopback, this machine and of server
Execute mkslave –O –B –C mca

Client machine
Change the nis domain name
        chypdom –B mca
Edit hosts file, and keep entries for loopback ,  this machine and of server
Execute mkclient –B mca
Check for ypbind with lssrc –s ypbind

HACMP Commands

logs
/tmp/hacmp.out                    Detailed event script output logged in 7 day rolling history
/var/adm/cluster.log           High level view of cluster events (No clean up on this file)
/usr/sbin/cluster/history/cluster.mmdd         Day by day view of cluster events. (one file / day of month)
/tmp/cm.log                           Clstrmgr messages
/tmp/cspoc.log                      Output from C-SPOC commands (similar to smit.log)
/tmp/emuhacmp.out             Output from event emulation


rdist  -b -f  /etc/disfile1       To distribute the files in disfile1 to all nodes in disfile1 in binary mode

Sample entry for disfile1
                                                HOSTS = ( root@node1 root@node3 )
                                                FILES = ( /etc/passwd /etc/security/passwd)
                                                ${FILES} -> ${HOSTS}

clstart -m -s -b -i -l                              To start cluster daemons (m-clstrmgr, s-clsmuxpd,
                                                                              b-broadcast message, -i-clinfo, -l cllockd)
clstop -f -N                                            To force shutdown cluster immediately without releasing resources
clstop -g -N                                           To do graceful shutdown immediately with no takeover
clstop -gr -N                                         To do graceful shutdown immediately with takeover

cldare  -t                                                To sync the cluster toplogy
cldare -t -f                                             To do the mock sync of topology
cldare -r                                                To sync the cluster resources
cldare -r -f                                             To do the mock sync of resources

clverify                                                  cluster verification utility

cllscf                                                      To list clustur topology information
cllsclstr                                                 To list the name and security level of the cluster
cllsnode                                                 To list the info about the cluster nodes
cllsnode -i node1                                  To list info about node1
cllsdisk -g shrg                                   To list the PVID of the shared hard disk for resource group shrg
cllsnw                                                    To list all cluster networks
cllsnw -n ether1                                   To list the details of network ether1
cllsif                                                       To list the details by network adapter
cllsif -n node1_service                       To list the details of network adapter node1_service
cllsvg                                                     To list the shared vgs which can be accessed by all nodes
cllsvg -g sh1                                         To list the shared vgs in resource group sh1
cllslv                                                      To list the shared lvs
cllslv -g sh1                                          To list the shared lvs in the resource group sh1
cllsdisk -g sh1                                     To list the PVID of disks in  the resource group sh1
cllsfs                                                      To list the shared  file systems
cllsfs -g sh1                                          To list the shared file systems in the resource group sh1
cllsnim                                                  Show info about all network modules
cllsnim -n ether                                   Show info about ether network module
cllsparam -n node1                              To list the runtime parameters for the node node1
cllsserv                                                  To list all the application servers

claddclstr -i 3 -n dcm                          To add a cluster definition with name dcm and id 3
claddnode                                              To add an adapter
claddnim                                                To add network interface module
claddgrp -g sh1 -r cascading -n n1 n2             To create resource group sh1 with nodes n1,n2 in cascade
claddserv -s ser1 -b /usr/start -e /usr/stop     Creates an application server ser1 with startscript as /usr/start
                                                                                and stop script as /usr/stop

clchclstr  -i 2 -n dcmds                       To change cluster definitions name to dcmds and id to 2
clchclstr -s enhanced                         To change the clustur security to enhanced
clchnode                                                To change the adapter parameters
clchgrp                                                  To change the resource group name or node relationship
clchparam                                             To change the run time parameters (like verbose logging)
clchserv                                                 To change the name of app. server or change the start/end scripts

clrmclstr                                               To remove the cluster definition
clrmgrp -g sh1                                     To delete the resource group sh1 and related resources
clrmnim                ether                      To remove the network interface module ether
clrmnode -n node1                               To remove the node node1
clrmnode -a node1_svc                       To remove the adapter named node1_svc
clrmres -g sh1                                     To remove all resources from resource group sh1
clrmserv  app1                                     To remove the application server app1
clrmserv ALL                                      To remove all applicaion servers

clgetactivenodes -n node1  To list the nodes with active cluster manager processes from cluster
                                                                manager on node node1
clgetaddr node1                                   returns a pingable address from node node1
clgetgrp -g sh1                                    To list the info about resource group sh1
clgetgrp -g sh1 -f nodes                     To list the participating nodes in the resource group sh1
clgetif                                                    To list interface name/interface device name/netmask associated with
                                                                a specified ip label / ip address of a specific node
clgetip sh1                                            To get the ip label associated to the resource group
clgetnet 193.9.200.2  255.255.255.0              To list the network for ip 193.9.200.2, netmask 255.255.255.0
clgetvg -l nodelv                                   To list the VG of LV nodelv

cllistlogs                                               To list the logs

clnodename -a node5                           To add node5 to the cluster
clnodename -o node5 -n node3          To change the cluster node name node5 to node3

clshowres                                              Lists resources defined for all resource group
clfindres                                                To find the resource group within a cluster

xclconfig                                               X utility for cluster configuration
xhacmpm                                               X utility for hacmp management
xclstat                                                    X utility for cluster status









SP Commands


Daemons

hats        Topology services               hatsd                                      ( /usr/sbin/rsct/bin/hatsctrl script)
hags       Group services                     hagsd                                     (/usr/sbin/rsct/bin/hagsctrl script)
haem      Event management              haemd                                    (/usr/sbin/rsct/bin/haemctrl script)
hr            Host responds                      hrd                                          (/usr/sbin/rsct/bin/hrctrl script)
pman      Problem management          pmand,pmanrmd  (/usr/sbin/rsct/bin/pmanctrl script)

fault_service_Worm_RTG_SP  (WORM)        Switch daemon on nodes (/usr/lpp/ssp/rc.switch  called by css_restart_node)

kadmind                                                The authentication database daemon for password changing and administration tools. Listens port 751.  It checks acl files admin.acl.(get,mod,add) in /var/kerberos/database/.k file for master key and /var/kerberos/databse/pricipal.pag, pricipal.dir for  authentication
database.
kerberos               Daemon that provides authentication services & ticket granting ticket for clients.
kpropd                   Daemon to receive update for a secondary database server
hardmon                Daemon that monitors and controls the state of SP hardware
                                It checks acl file /spdata/sys1/spmon/hmacls

install_cw                                             To complete PSSP installation on cws
                                                                (Installs PSSP programs for SMIT panels
                                                                Starts and configures SDR
                                                                Sets node number 0 for cws in ODM
                                                                Creates hmacls file with rood.admin entry in
                                                                Starts and configure PSSP daemons
Configures default partition)
setup_authent                                      To setup workstation as SP authentication server
                                                                (Creates /etc/krb.conf, /etc/krb.realms files
                                                                Creates authentication database using kdb_edit command
                                                                Create master key file /.k  using kstash command
                                                                Adds kadmin and kerberos to inittab file and starts them
                                                                Define initial auth. admin (eg:- root.admin) using kdb_edit command
                                                                Creates Kerberos ACLS (admin_acl.get,mod,add files)
                                                                Execute kinit for root.admin and creates local service principals
                                                                (hardmon.cws, rcmd.cws)
                                                                Creates /.klogin file and add admin principal to it
                                                                Creates /etc/krb-srvtab file using ext_srvtab command)

setup_server                                        To setup CWS as BIS
                                                               
splst_versions -G -t                             To check the PSSP versions in all nodes
spmon_ctest                                         To verify system monitor configured properly
spmon_itest                                          To verify system monitor installed properly & operational
SYSMAN_test                                     To verify the system management component
CSS_test                                               To verify communication subsystem

SDR_test  -l si                                     To verify SDR and logs the errors in file si
SDRListClasses                                  To list the class name in the SDR
SDRArchive si                                     To backup SDR  in the directory /spdata/sys1/sdr/archives with name
backup.<year><Julian day>.<hour><minute>.si
sprestore_config  backup.<year><Julian day>.<hour><minute>.si
                                                                To restore  SDR and  partion sensitive subsystems
SDRGetObjects Syspar                     To get the system partition info
SDRGetObjects syspar_map            To get the system partition map (with node info)
SDRGetObjects Adapter node_number  netaddr
                                                                To get the node number and net address in the Adapter class
SDRDeleteObjects Adapter netaddr==193.9.200.227
                                                                To delete class Adapter with netaddr value 193.9.200.227
SDRChangeAttrValues Node node_number==9 bootp_response==install
                                                                To change the boot response as install on node with node number 9
SDRWhoHasLock  <class_name>  Returns the transaction ID of a lock on a specified class
SDRClearLock <class_name>         To unlock an SDR class

syspar_ctrl -G -A                                To add and restart all system partition sub systems
syspar_ctrl -G -D                                To stop and delete all system partition sub systems
syspar_ctrl -R                                      To restore all system partition sub systems in current partition
syspar_ctrl -E                                      To list all system partition sub systems
syspar_ctrl -s                                       To start all system partition sub systems in current partition
syspar_ctrl -k                                      To stop all system partition sub systems in current partition
syspar_ctrl -r                                       To refresh all system partition sub systems in current partition


ngcreate  -s 1:1 si                               To create node group si with 1st node in 1st frame
ngcreate -n 1 2 3 si                             To create node group si with 1st 2nd and 3rd nodes
ngcreate -N ng1,ng2 si                      To create node group si with node groups ng1 and ng2
ngcreate  -w n1,n2 si                          To create node group si with host name  n1 and n2
ngcreate -ae n1,n2 si                          To create node group si with all nodes in the current partition
                                                                excluding hosts n1 and n2
nglist                                                     To list node groups in current partition
nglist -G                                                To list node groups globally
ngfind si                                                To find all node groups which contain node group si
ngnew si1 si2 si3                                                To create 3 node groups with names si1 si2 and si3
ngnew -G si1 si2 si3                           To create 3 node groups globally with names si1 si2 and si3
ngresolve   -G -n si                              To resolve the nodes in the node group si as node numbers
                                                                with global option
ngresolve  -w si                                    To resolve the nodes in the node group si as fully qualified
                                                                host name
ngresolve -d si                                      To resolve the nodes in the node group si as fully qualified
                                                                ip address
ngdelete si si1                                      To remove node groups si and si1
ngdelete -u si                                        To remove node group si but leave entries in other node groups
                                                                which is having the entries in it
ngclean -Ga                                          To clean up all node groups
ngaddto si  1 2                                      To add nodes 1 and 2 to the existing node group si
ngaddto si 1 2 ng1                               To add nodes 1,2 and node group ng1 to node group si
ngdelfrom si 1 2                                  To remove nodes 1 and 2 from  node group si
ngdelfrom si 1 2 ng1                          To remove nodes 1, 2 and node group ng1 from node group si

spled  -G                                                To display leds of nodes in a multi partition system
spled       or  spmon -L                         To display leds of nodes in the current partion

spmon -p off frame2/node3                To power off node3 in frame 2
spmon -p on frame2/node3 To power on node 3 in frame 2
spmon -G -p on frame2/node3           To power on node3/frame 2 if it is outside current partition
spmon -k service /frame2/node3      To change the key settings to service
spmon -p off frame1                            To power off frame1
spmon -K frame1/node1                     To see the key settings of frame1/node1
spmon -reset frame1/node1               To reset
spmon -open frame1/node1                To open a tty on frame1/node1==(s1term -w 1 1)
spmon -d                                                To run the diag in the current partition
spmon -G -d                                           To run the diag globally

hmmon  -V 1:1                                     Displays a descriptive list of symbolic variable names
hmmon -Q -s 1:1                                  Displays the state of node1 in frame 1 and exists
hmmon -q -s 1:1                                   Displays and monitors continuously

hmreinit                                                To stop and restart hardmon

hmcmds -G off all                                To power off all hardware
hmcmds -G off 1:3                               To power off slot 3 in frame 1
hmcmds -G on 1:3                               To power on slot 3 in frame 1
hmcmds -v -G boot_supervisor 1:1   To reset the power of node_supervisor card on slot 1 frame 1
                                                                (Use full to close the opened ttys on nodes)
hmcmds secure l 1-3:2                       To change the key in secure mode for slot 2 in frame 1 2 and 3
hmcmds -v synch_reset                      Perform sync reset. To clear the switch errors
hmcmds -v power_on_reset               Perform sync reset and do self test of switch chips

cstartup  -G all                                     To startup all nodes globally
cstartup -N 1 2 4-8                              To startup nodes 1,2 and 4 to 8
cstartup -g si                                        To startup node group si
cstartup -GZ all                                   To startup all nodes. With Z it will restart the nodes which are already
                                                                running (otherwise command will exit)
cstartup -k all                                      To verify the startup with sequence file (StartSeq)
cstartup -E all                                       To startup all nodes ignoring the sequence file

cshutdown -F node1                             To shutdown node1 immediately
cshutdown -h node1                             To halt the node node1
cshutdown -g si                                    To shutdown the nodes in the node group si
cshutdown -G -N 1 3 4-7                     To shutdown nodes 1 3 and 4 to 7 regardless partition
cshutdown -X -N 1 2 3                        To shutdown nodes 1 2 and 3 ignoring sequence file

hostlist -av                                            To list sp host name which is active
hostlist -avd                                          To list the hosts in ipaddress which are active
hostlist -dw node1                                Returns the ip of the node node1
hostlist -N si                                         List the host names in the node group si
hostlist -s 1-4:4                                   List the hostname of the node in 4th slot in frames 1-4

nodecond -n 1 1                                    To get the ehternet address of the node 1 in frame 1
nodecond 1 1                                         To network boot the node 1 in frame 1

splstdata -h                                           To list the hardware info (equivalent to lscfg )
splstdata -i                                            To list the network adapter data (equivalent to netstat -in)
splstdata -v                                            To list VG info on nodes
splstdata -t                                            To list extension node config
splstdata -b                                            To list boot install info
splstdata -n                                           To list node information
splstdata -s                                            To list node switch information
splstdata -d                                            To list file system info (equivalent to df)
splstdata -p                                            To list SP partition info
splstdata -e                                            To list the sp environment variables like ntp_config, amd_config
Efence                                                    To display all nodes fenced
Efence  193.9.1.2 193.9.1.5               To fence nodes with ips 193.9.1.2 and 3
Efence node1 node3                             To fence nodes node1 and node3
Efence -autojoin  node1                      To fence out but will unfence it after reboot


Eunfence  193.9.1.2 193.9.1.5          To unfence nodes with ips 193.9.1.2 and 3
Eunfence node1 node3                        To unfence nodes node1 and node3

Estart                                                     To start sp switch
Estart -autounfence -0                        To start sp switch and turn off autounfence feature
                                                                (1 for autounfence enabled)

Eunpartition                                         To prepare a system partition for repartitioning

delnimclient -l 1 2 3                            To delete nim client definition for nodes 1 2 and 3 from NIM master
mknimclient -l 1 2 3                           To make node 1 2 and 3 as NIM clients
delnimmast -l 1 17 33                         To unconfigure nodes 1 17 and 33 as NIM masters and remove filesets
mknimmast -l 1 17 33                        To make nodes 1 17 and 33 as NIM masters

lshacws                                                  To list the status of the CWS

ntpdate 90.1.2.1                                   Sets date and time by enquiring ntp server 90.1.2.1

spbootlist -l 1 2                                    To set the bootlist on nodes 1 and 2

nodecond 1 4                                         To network boot the node 4 in frame 1
nodecond -n 1 4                                    To fetch the ethernet address of node 4 in frame 1
sphrdwrad  1 3 2                  To fetch mac address  for node 3 and 4 in frame 1

setup_authent                                      To setup a cws to use kerberos authentication
kdb_destroy                                          To destroy the kerberos database
create_krb_files                                 Searches for nodes in install/Customise mode and create  krb-srvtab file
                                                                for those nodes.   (Creates in tftpboot directory of CWS.)
ext_srvtab -n node1                             To extract service key files from the database for instance node1
ext_srvtab -n SPbgAdm                      To extract service key files from the database for instance SPbgAdm
                                                                (Creates in the present directory with name <instance>-new-srvtab)
spsetauth -d k4 std                              To set the authentication methods as k4 and standard
chauthpar  k4 std                                To change the authentication methods as k4 and std

kpasswd                                 To change the kerberos principals password

lsauthent                                               To list the authentication table

k4init siju                                             To get the kerberos ticket for principal siju
k4init -v siju                                         To get the same as above but give verbose output
k4init -i siju                                         To get the same but the  machine will ask for the instance
k4init -r siju                                        To get the same for a different realm (U can specify realm)
k4init -l siju                                         To get the same for the life time in minutes which u specify

rcmdtgt                                                  To obtain a maximum life time ticket for rcmd services on local node

k4list                                                     To list the ticket cache and principal’s name
k4list -srvtab                                        To list the contents of the server key file

chkp -l  6 siju                                       To change the life time of the principal siju to 30  minutes (6 x 5)
chkp -e 2001-5-23 siju                       To change the expiry date of principal siju to 2001 may 23

lskp -p                                                    To list the predefined kerberos principals
lskp -s                                                    To list the kerberos service principals
lskp -c                                                    To list the kerberos client principals
lskp siju abc                                         To list the principals of siju and abc

rmkp siju                                              To remove the principal siju
rmkp -n siju                                         To remove the principal siju without prompting for confirmation
rmkp -v siju                                          To remove the principal with verbose output

kdb_edit                                                To change the attributes of  the kerberos principals
kdb_edit -n                                            To avoid asking master key and get it from .k file

kdb_util dump /si.bak                         To backup the kerberos database to si.bak file
kdb_util load  /si.bak                          To restore the kerberos database from file si.bak.
kdb_util new_master_key To change the master key

kadmin                                                  To add,delete,see,change password,change admin passwd of kerberose
kadmin ank                                          To add a new kerberos principal
kadmin cpw                                           To change the password of a principal
kadmin cap                                           To change admin password
kadmin get                                            To get the details of a principal
kadmin dest                                          To destroy admin ticket

kstash                                                    To save the master key in the .k file

kdb_init                                 To initialize the kerberos system

ksrvutil list                                          To list the principals and version number in the server key file
ksrvutil -f /etc/srvtab.bak list           To list the principals in the file /etc/srvtab.bak
ksrvutil change                                   To change the key version in the default srvtab file
ksrvutil delete                                      To delete the keys in the /etc/krb-srvtab file
ksrvutil -f /etc/srvtab.bak delete      To delete the keys in the /etc/srvtab.bak file
spacs_cntrl block user1                    To block user1 on the node
spacs_cntrl unblock user1               To unblock user1
spacs_cntrl deny user1                      To deny user1
spacs_cntrl allow user1                     To allow user1
spacs_cntrl -f /tmp/si deny                To deny the list of the users in the file /tmp/si
cw_allowed                                            List of users to be allowed to login to CWS
cw_restrict_login                               Script which will deny user to login to cws and allow them to change
the passwd  (files are /usr/lpp/ssp/config/admin directory and entry for
second file will be in /etc/profile file)

spmkuser id=1234 pgrp=system  groups=system,bin home=node1:/home/siju  siju
                                                                To create SP user siju with id 1234, primary groups system, secondary
                                                                groups system,bin and home directory home/siju of node1
sprmuser -ipr siju                               To remove the SP user siju (I for interactive, p for removing info from
                                                                passwd file and r for removing the home directory)

splsuser  -c siju                                   To list the attributes of sp user siju in column format
splsuser -f siju                                     To list the attributes of sp user siju in stanza format

spchuser groups=dev,system sh=/bin/ksh siju
                                                                To change the shell to ksh and secondary groups to dev,
                                                                system of SP user siju


supper -v                                                To go to the supper prompt in verbose mode
supper update                                       To update all file collections
supper status                                        To see the status of the file collections
supper when                                         To list when last updation occured
supper where                                        To show current servers for updation
supper log                                             To show summary of last or current updation
supper rlog                                           To show the details of last of current updation
supper file user.admin                       To list the files in the file collection user.admin
supper install siju                               To install the file collection siju
supper remove siju                              To remove file collection siju
supper update user.admin  To update file collection user.admin
supper diskinfo                                    To show the diskspace and current VG


Procedure to Build a file collection with name siju  for files in /home/siju

1) go to /var/sysman/sup
2) create dir siju
3) change ownership and group of siju to bin
4) copy contents of /var/sysman/sup/user.admin to siju
5) edit list file for including and omitting  files in /home/siju directory
    It should contains entry like the following
                               
                             symlinkall
                                upgrade ./home/siju
                                omit ./home/siju/abc
                                omitany ./home/siju/s*

6) Add a symbolic link to siju file in lists directory to list in siju directory
                ie ln -s /var/sysman/sup/siju/list /var/sysman/sup/lists/siju
7) Update /var/sysman/file.collections file with following entry
                primary siju - / - / EDO power no
8) Update sup.admin file collection to reflect the changes made to file.collections
                dsh -av supper update sup.admin
9)    Install file collection siju in the nodes
                dsh -av supper install siju

sysctld                                                   Sysctl server daemon
/etc/sysctl.conf                                     Sysctl configuration file

setauth -cmd  svcconnect NONE       To allow non kerberos users to execute sysctl commands
(Entry in sysctl.conf file)
setauth -cmd pdf {ACL  /etc/si.acl} To change the acl file for pdf command to /etc/si.acl
(Entry in sysctl.conf file)

/etc/sysctl.acl                                       Default acl file for sysctl


sysctl -h node1                                     Opens a sysctl command interface for node node1
sysctl -h node1 aclcheck siju            To check entry for siju in the default acl file (sysctl.acl)
sysctl -h node1 -f /etc/si.acl siju       To check entry for siju in the acl file /etc/si.acl
sysctl -h node1 info commands         To list the authorized commands for the current principal
sysctl -h node1 acladd -p siju            To add the principal siju to the default ACL file
sysctl -h node1 -f /etc/si.acl acladd -p siju     
To add the principal siju to /etc/si.acl ACL file
sysctl -h node1 acldelete -p siju        To delete the principal siju to the default ACL file
sysctl -h node1 -f /etc/si.acl acldelete -p siju
To delete the principal siju to /etc/si.acl ACL file
sysctl -h node1 acllist                         To list the entries in the default acl file
sysctl -h node1 -f /etc/si.acl acllist  To list the entries in /etc/si.acl  file
sysctl -h node1 aclcreate -p root.admin -p siju  -f /etc/si.acl
                                                                To create acl file /etc/si.acl with the entries root.admin and siju
sysctl -h node1 checkauth -cmd pdf
                                                                To check authorization for command pdf for the current user
sysctl -h node1 confadd include /etc/si.acl
                                                                To include the acl file si.acl in the sysctl.conf file
sysctl -h node1 confdelete include /etc/si.acl
                                                                To remove the acl file si.acl from sysctl.conf file
sysctl -h node1 svcrestart                  To restart the sysctld daemon on node node1


                                                               
Steps to create a Syctl application

Task :- User siju (kerberos principal siju.adm) should get the permission to start a subsystem by executing the command substart.  Permission should not be given to other users.

1)             Create the client application  substart  in /usr/bin directory of cws with following contents

            if [ $# -gt 2 ]
                                then echo "Arguments exceed the limit"
                                exit 1
                fi
                /usr/lpp/ssp/bin/hostlist -n $1 | /usr/bin/sysctl -c - substart_proc $2


                In the above script if condition will check for the number of arguments and execute procedure on
                corresponding host

2)             Change the mode to executable
                chmod 755 /usr/bin/substart

3)             Create server application substart.tcl with a procedure substart_proc with following contents

                create proc substart_proc {SubSystem} AUTH {
                global SCUSER
                if [ aclcheck -f /etc/substart.acl $SCUSER ] {
                                exec /etc/substart.srv $SubSystem
                                return
                                }
                }

                if condition in the above example checks for kerberos user in the acl file /etc/substart.acl
                If the condition is true it execute the command /etc/substart.srv with arguments passed by
                substart command

4)             Create the script   substart.srv with following contents
            startsrc -s $2

                This script execute the command startsrc with the argument passed by the substart command.

5)             Change the mode to executable
                            chmod 755 /etc/substart.srv

6)             Create acl file substart.acl  with the entry for user siju
                #acl#
                _PRINCIPAL siju.adm@CWS

7)             Add the application to the sysctl by adding following line to sysctl.conf file
                include /etc/substart.tcl

8)             Distribute the files to all nodes
            pcp -av /usr/bin/substart
                pcp -av /etc/substart.tcl
                pcp -av /etc/substart.srv
                pcp -av /etc/substart.acl
                pcp -av /etc/sysctl.conf

9)             Restart the sysctld daemon to get the new information on cws and on all nodes

10)           Get the kerberos ticket for user siju and execute following command
            substart 3 lpd

                This should start the lpd daemon on node 3

11)         Try the above command with any other kerberos ticket. Result should be negative

NIM Commands

nimconfig -a pif_name=en0 -a netname=net1  To initialise the NIM master with network name net1
nimconfig -r                                                To rebuild /etc/niminfo file which contains the variables for NIM
nim -o define -t lpp_source -a source=/dev/cd0 -a server=master –a location=
/export/lpp_source1 lpp_source1                                             
To define  lpp_source1 image in /export/lpp_source/lpp_source         directory from source cd0

nim -o define -t mksysb -a server=master  -a location=/resources/mksysb.image mksysb1
                To define mksysb resource mksysb1, from source /resources/mksysb.image on master

nim -o remove inst_resource                      To remove the resource inst_resource
nim -o check lpp_source1                           To check the status of  lpp_source lpp_source1
nim -o allocate -a spot=spot1 -a lpp_source=lpp_source1 node1
                                                     To allocate the resources spot1 and lpp_source1 to the the client node1
nim -o bos_inst node1                                To initialise NIM for the BOS installation on node1 with the allocated resources                                                           
nim  -o dkls_init  dcmds                                 To initialize the machine dcmds as diskless operation
nim -o dtls_init dcmds                                    To initialize the machine dcmds for dataless operation
nim -o cust dcmds                                            To initialize the machine dcmds for customize operation
nim -o diag dcmds                                            To initialize the machine dcmds for diag operation
nim -o maint dcmds                                        To initialize the machine dcmds for maintenance operation
nim -o define -t standalone -a platform=rspc -a if1="net1 dcmds xxxxx" -a cable_type1=bnc dcmds
                To define the machine dcmds as standalone with platform as rspc and network as net1 with cable
type bnc and mac address xxxxx
nim -o unconfig master                                   To unconfigure nim master master
nim -o allocate -a spot=spot1 dcmds To allocate the resource spot1 from machine dcmds
nim -o deallocate -a spot=spot1 dcmds             To de allocate the resource spot1 from machine dcmds
nim -o remove dcmds                                          To remove machine dcmds after removing all resources                             associated to it.                                                                                     
nim -o reboot dcmds                                           To reboot ther client dcmds
nim -o define -t lpp_source -a location=/software/lpp1 -a server=master -a source=/dev/cd0 lpp1
                To define lppsource lpp1 on master at /software/lpp1 directory from source device /dev/cd0
lsnim                                                                      To list the nim resources
lsnim -l  dcmds                                                     To list the detailed info about the object dcmds
lsnim -O dcmds                                                    To list the operation dcmds object can support
lsnim -c resources dcmds                                  To list the resources allocated to the machine dcmds
nimclient               The client version of nim command (User can obtain same results of nim in server )

* Article Source from : Internet